Discussion:
[MikroTik] Mikrotik script to add queues
James Lupolt
2004-05-25 06:13:31 UTC
Permalink
Hi all,

I am having some difficulty writing a script to add queues and any help
would be much appreciated.

Here is the script I am using (with dummy IP addresses substituted):

:for e from=140 to=190 step=1 do={
/queue simple add name=(127.0.0. . $e) \
dst-address=(127.0.0. . $e) interface=wireless \
limit-at=262144/262144 max-limit=524288/262144 \
burst-limit=2621440/1048576 burst-threshold=524288/262144 burst-time=10/10
}

It does successfully add the rules, however the problem is I cannot figure
out how to add the /32 to the dst-address, so all rules are created with a
/0 subnet mask. Could someone let me know the syntax to do this correctly?

For example "add name=(66.234.175. . $e)/32" does not work, and neither
does "add name=(66.234.175. . $e"/32")" etc.

Thank you!

James Lupolt
2Fast Communications
www.2fastcom.com

_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
To post to the list, address emails to ***@bruno.pmi.lv
To unsubscribe/subscribe: email to RouterOS-***@bruno.pmi.lv ,
with text in the body "unsubscribe <password>" or "subscribe"
Raivo
2004-05-25 06:44:51 UTC
Permalink
Post by James Lupolt
Hi all,
I am having some difficulty writing a script to add queues and any help
would be much appreciated.
:for e from=140 to=190 step=1 do={
/queue simple add name=(127.0.0. . $e) \
dst-address=(127.0.0. . $e) interface=wireless \
limit-at=262144/262144 max-limit=524288/262144 \
burst-limit=2621440/1048576 burst-threshold=524288/262144 burst-time=10/10
}
It does successfully add the rules, however the problem is I cannot figure
out how to add the /32 to the dst-address, so all rules are created with a
/0 subnet mask. Could someone let me know the syntax to do this correctly?
For example "add name=(66.234.175. . $e)/32" does not work, and neither
does "add name=(66.234.175. . $e"/32")" etc.
Try instead "add name=(66.234.175. . $e . "/32")"

Raivo
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
To post to the list, address emails to ***@bruno.pmi.lv
To unsubscribe/subscribe: email to RouterOS-***@bruno.pmi.lv ,
with text in the body "unsubscribe <password>" or "subscribe"
nondito
2004-05-25 06:39:15 UTC
Permalink
Hello,

We are trying to solve a mystrious VoiIp problem in
our network. Some of our VoIP client complain that
they fail to use our line for VoIP.

Searching through the MT archive, we have found a
problem some one else had, which could suggest that
may be our MT box is causing the problem.

Our MT box (2.7.18) is running as a bridge just to
throttle the bandwidth, we do no perfoem any NAT or
any other operatiosn from the MT box. Do we still have
to disable the "h323 module in /ip firewall
service-port" from the 2.7.18 box? Could it be a
problem for us too?

Thanks,

Nondito.
Hi,
Disable h323 module in /ip firewall service-port. (It
can be disabled only
via shell and not via winbox.)
It's common problem on all linux machines with loaded
nat module for h323

Regards,
Dimitar Kazakov
----- Original Message -----
From: "Chernar" <chernar at yahoo.com>
To: <routeros at bruno.pmi.lv>
Sent: 15 ??? 2003 ?. 15:36
Subject: [MikroTik] Voip Problem
Hello ,
We are using a cisco ATA for voipto call
Internationally and the remote side equipment is
Quintum tenor .
Until Yesterday the quintum is behind Mikrotik
2.6.13
and everything is fine .We upgraded the box to 2.7.2
and now the voip is not working ..Ie. the call is
not
completing at all .
Whats the problem .Did any one had similar problem ?
WE tested by removing the quintum behind mikrotik
and
keeping it directly to router and it works fine .
There are no Firewalls in the mikrotik .
Can any one suggest me the remedy
?
Cher
__________________________________
Do you Yahoo!?
Friends. Fun. Try the all-new Yahoo! Messenger.
http://messenger.yahoo.com/
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
To post to the list, address emails to ***@bruno.pmi.lv
To unsubscribe/subscribe: email to RouterOS-***@bruno.pmi.lv ,
with text in the body "unsubscribe <password>" or "subscribe"
Dimitar Kazakov
2004-05-25 16:11:29 UTC
Permalink
Yes,
You have to disable it.
Otherwise it breaks the setup message.

----- Original Message -----
From: "nondito" <***@yahoo.com>
To: "General questions about MikroTik RouterOS" <***@bruno.pmi.lv>
Sent: Tuesday, May 25, 2004 9:39 AM
Subject: [MikroTik] VoIP issue on a MT 2.7.18
Post by nondito
Hello,
We are trying to solve a mystrious VoiIp problem in
our network. Some of our VoIP client complain that
they fail to use our line for VoIP.
Searching through the MT archive, we have found a
problem some one else had, which could suggest that
may be our MT box is causing the problem.
Our MT box (2.7.18) is running as a bridge just to
throttle the bandwidth, we do no perfoem any NAT or
any other operatiosn from the MT box. Do we still have
to disable the "h323 module in /ip firewall
service-port" from the 2.7.18 box? Could it be a
problem for us too?
Thanks,
Nondito.
Hi,
Disable h323 module in /ip firewall service-port. (It
can be disabled only
via shell and not via winbox.)
It's common problem on all linux machines with loaded
nat module for h323
Regards,
Dimitar Kazakov
----- Original Message -----
From: "Chernar" <chernar at yahoo.com>
To: <routeros at bruno.pmi.lv>
Sent: 15 ??? 2003 ?. 15:36
Subject: [MikroTik] Voip Problem
Hello ,
We are using a cisco ATA for voipto call
Internationally and the remote side equipment is
Quintum tenor .
Until Yesterday the quintum is behind Mikrotik
2.6.13
and everything is fine .We upgraded the box to 2.7.2
and now the voip is not working ..Ie. the call is
not
completing at all .
Whats the problem .Did any one had similar problem ?
WE tested by removing the quintum behind mikrotik
and
keeping it directly to router and it works fine .
There are no Firewalls in the mikrotik .
Can any one suggest me the remedy
?
Cher
__________________________________
Do you Yahoo!?
Friends. Fun. Try the all-new Yahoo! Messenger.
http://messenger.yahoo.com/
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
with text in the body "unsubscribe <password>" or "subscribe"
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
To post to the list, address emails to ***@bruno.pmi.lv
To unsubscribe/subscribe: email to RouterOS-***@bruno.pmi.lv ,
with text in the body "unsubscribe <password>" or "subscribe"
nondito
2004-05-25 16:51:50 UTC
Permalink
Two of our clients can do VoIP (Quintum in our network
and Cisco in remote place) having it enabled.

I was wondering if everyone else has problem for it,
how those two clients can do it successfully!

I just have disabled it and waiting for the results.

Thansk for your reply.
Post by Dimitar Kazakov
Yes,
You have to disable it.
Otherwise it breaks the setup message.
----- Original Message -----
To: "General questions about MikroTik RouterOS"
Sent: Tuesday, May 25, 2004 9:39 AM
Subject: [MikroTik] VoIP issue on a MT 2.7.18
Post by nondito
Hello,
We are trying to solve a mystrious VoiIp problem
in
Post by nondito
our network. Some of our VoIP client complain that
they fail to use our line for VoIP.
Searching through the MT archive, we have found a
problem some one else had, which could suggest
that
Post by nondito
may be our MT box is causing the problem.
Our MT box (2.7.18) is running as a bridge just to
throttle the bandwidth, we do no perfoem any NAT
or
Post by nondito
any other operatiosn from the MT box. Do we still
have
Post by nondito
to disable the "h323 module in /ip firewall
service-port" from the 2.7.18 box? Could it be a
problem for us too?
Thanks,
Nondito.
Hi,
Disable h323 module in /ip firewall service-port.
(It
Post by nondito
can be disabled only
via shell and not via winbox.)
It's common problem on all linux machines with
loaded
Post by nondito
nat module for h323
Regards,
Dimitar Kazakov
----- Original Message -----
From: "Chernar" <chernar at yahoo.com>
To: <routeros at bruno.pmi.lv>
Sent: 15 ??? 2003 ?. 15:36
Subject: [MikroTik] Voip Problem
Hello ,
We are using a cisco ATA for voipto call
Internationally and the remote side equipment is
Quintum tenor .
Until Yesterday the quintum is behind Mikrotik
2.6.13
and everything is fine .We upgraded the box to
2.7.2
Post by nondito
and now the voip is not working ..Ie. the call
is
Post by nondito
not
completing at all .
Whats the problem .Did any one had similar
problem ?
Post by nondito
WE tested by removing the quintum behind
mikrotik
Post by nondito
and
keeping it directly to router and it works fine
.
Post by nondito
There are no Firewalls in the mikrotik .
Can any one suggest me the remedy
?
Cher
__________________________________
Do you Yahoo!?
Friends. Fun. Try the all-new Yahoo! Messenger.
http://messenger.yahoo.com/
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS
QUESTIONS
Post by nondito
To post to the list, address emails to
To unsubscribe/subscribe: email to
with text in the body "unsubscribe <password>" or
"subscribe"
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
To post to the list, address emails to
To unsubscribe/subscribe: email to
with text in the body "unsubscribe <password>" or
"subscribe"





__________________________________
Do you Yahoo!?
Friends. Fun. Try the all-new Yahoo! Messenger.
http://messenger.yahoo.com/
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
To post to the list, address emails to ***@bruno.pmi.lv
To unsubscribe/subscribe: email to RouterOS-***@bruno.pmi.lv ,
with text in the body "unsubscribe <password>" or "subscribe"
Mohammad A. Rahman
2004-05-26 16:31:20 UTC
Permalink
We did not disable it.

We have some quintums running in our network with no problem.

But in the past some clients did mention problem in setting up voice calls.

Could this be the reason for some call (H323) to break yet some to establish?
Post by Dimitar Kazakov
Yes,
You have to disable it.
Otherwise it breaks the setup message.
----- Original Message -----
Sent: Tuesday, May 25, 2004 9:39 AM
Subject: [MikroTik] VoIP issue on a MT 2.7.18
Post by nondito
Hello,
We are trying to solve a mystrious VoiIp problem in
our network. Some of our VoIP client complain that
they fail to use our line for VoIP.
Searching through the MT archive, we have found a
problem some one else had, which could suggest that
may be our MT box is causing the problem.
Our MT box (2.7.18) is running as a bridge just to
throttle the bandwidth, we do no perfoem any NAT or
any other operatiosn from the MT box. Do we still have
to disable the "h323 module in /ip firewall
service-port" from the 2.7.18 box? Could it be a
problem for us too?
Thanks,
Nondito.
Hi,
Disable h323 module in /ip firewall service-port. (It
can be disabled only
via shell and not via winbox.)
It's common problem on all linux machines with loaded
nat module for h323
Regards,
Dimitar Kazakov
----- Original Message -----
From: "Chernar" <chernar at yahoo.com>
To: <routeros at bruno.pmi.lv>
Sent: 15 ??? 2003 ?. 15:36
Subject: [MikroTik] Voip Problem
Hello ,
We are using a cisco ATA for voipto call
Internationally and the remote side equipment is
Quintum tenor .
Until Yesterday the quintum is behind Mikrotik
2.6.13
and everything is fine .We upgraded the box to 2.7.2
and now the voip is not working ..Ie. the call is
not
completing at all .
Whats the problem .Did any one had similar problem ?
WE tested by removing the quintum behind mikrotik
and
keeping it directly to router and it works fine .
There are no Firewalls in the mikrotik .
Can any one suggest me the remedy
?
Cher
__________________________________
Do you Yahoo!?
Friends. Fun. Try the all-new Yahoo! Messenger.
http://messenger.yahoo.com/
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
with text in the body "unsubscribe <password>" or "subscribe"
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
with text in the body "unsubscribe <password>" or "subscribe"
_______________________________________________
ALL POSTS SHOULD BE ABOUT GENERAL ROUTEROS QUESTIONS
To post to the list, address emails to ***@bruno.pmi.lv
To unsubscribe/subscribe: email to RouterOS-***@bruno.pmi.lv ,
with text in the body "unsubscribe <password>" or "subscribe"

Loading...